AHCI et Windows 7

Publié dans: Forum Windows
  • Photo du profil de muy
    muy le : 15 novembre 2011 à 21 h 29 min #10983

    Bonjour
    J’ai un PC avec une carte mère ASUS M2A-MX, Athlon 64 X2 5200+ et 2 disques SATA
    Sur l’un des disques, j’ai Windows 7.
    Sur l’autre disque, j’ai l’intention d’installer OSX (faire un hackintoch) avec une distribution iATKOS.
    Quand j’ai installé Win7, j’ai laissé la carte mère avec les options par défaut, SATA=SATA
    Mais pour installé OSX, il faut que le SATA soit en AHCI.
    Je me suis dit “autant rester en AHCI pour tout”. J’ai donc essayé de démarrer Win7 en mode AHCI.
    Ca démarre. Je n’ai pas d’écran bleu comme on le dit. Mais je met au moins 10 mn avant d’avoir l’invité de connexion.
    J’ai bien lu par çi, par là, qu’il y a une méthode pour activer le mode AHCI quand Win7 est déjà installé :
    regedit
    HKEY_LOCAL_MACHINE, System, CurrentControlSet, Services, msahci
    Start=0
    Mais apparemment, ca n’y fait rien du tout
    Est-ce que que quelqu’un pourrait avoir des idées ?
    Merci

    Photo du profil de thierryiv
    thierryiv le : 16 novembre 2011 à 15 h 15 min #16660

    Bonjour,

    Essayes ceci:
    Fermez toutes les applications Windows.
    Cliquez sur Démarrer, tapez regedit dans la zone de recherche du menu démarrer, puis appuyez sur ENTRÉE.
    Si la boîte de dialogue Contrôle de compte d’utilisateur s’affiche, cliquez sur Continuer.
    Recherchez l’une des sous-clés de Registre suivantes et cliquez dessus :
    HKEY_LOCAL_MACHINESystemCurrentControlSetServicesmsahci
    HKEY_LOCAL_MACHINESystemCurrentControlSetServicesiastorV
    Dans le volet à droite, dans la colonne Nom, clic droit sur la clef Démarrer (Start) , puis cliquez sur Modifier.
    Dans la zone Données de la valeur, tapez 0, puis cliquez sur OK.
    Dans le menu Fichier, cliquez sur Quitter pour quitter l’Éditeur du Registre.

    Ou

    Telecharge FixIt et execute le. Il va te proposer de passer de IDE en AHCI automatiquement à condition que tes disques durs supportent NCQ (Native Command Queuing)

    Photo du profil de muy
    muy le : 16 novembre 2011 à 16 h 39 min #16662

    Merci de cette 1ère réponse.
    Pour la 1ère clé de registre, c’est ce que j’ai déjà fait.
    Je vais donc essayer en modifiant aussi la 2ème clé.

    Mais je pourrais très bien essayer la 2ème méthode (Fixit de Microsoft).
    Mais si les disques ne supportent pas le NCQ, qu’est-ce que ça entraine ?
    A bientôt

    Photo du profil de thierryiv
    thierryiv le : 16 novembre 2011 à 18 h 30 min #16664

    Regarde ici: topic1131.html
    Dans le Gestionnaire peripherique tu peux verifier si le pilote AHCI est installé. Au pire tu auras un message d’ erreur.

    Donne moi la reference des disques durs stp.

4 sujets de 1 à 4 (sur un total de 4)

Vous devez être connecté pour répondre à ce sujet.